summaryrefslogtreecommitdiff
path: root/ext/openssl/lib/openssl.rb
diff options
context:
space:
mode:
authornahi <nahi@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2011-07-25 06:30:07 +0000
committernahi <nahi@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2011-07-25 06:30:07 +0000
commit0a9b952c6f314665af1a58f6f411f752343e9691 (patch)
treeeca0a7253d050794c0f7d851f323ecaa83c49811 /ext/openssl/lib/openssl.rb
parent8c30497aaefac8e4b11fd1f564509c75bb6a249b (diff)
* ext/openssl/lib/openssl.rb: End of transition period introduced by
[ruby-dev:38018]. From the next version of 1.9.3, you should use require "openssl" instead of require "openssl/ssl" and require "openssl/x509" git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@32664 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'ext/openssl/lib/openssl.rb')
-rw-r--r--ext/openssl/lib/openssl.rb4
1 files changed, 1 insertions, 3 deletions
diff --git a/ext/openssl/lib/openssl.rb b/ext/openssl/lib/openssl.rb
index fb215cd..19a4382 100644
--- a/ext/openssl/lib/openssl.rb
+++ b/ext/openssl/lib/openssl.rb
@@ -21,6 +21,4 @@ require 'openssl/cipher'
require 'openssl/config'
require 'openssl/digest'
require 'openssl/x509'
-require 'openssl/ssl-internal'
-require 'openssl/x509-internal'
-
+require 'openssl/ssl'