summaryrefslogtreecommitdiff
path: root/ext/openssl/extconf.rb
diff options
context:
space:
mode:
authorgotoyuzo <gotoyuzo@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2004-01-20 05:49:14 +0000
committergotoyuzo <gotoyuzo@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2004-01-20 05:49:14 +0000
commitc4fc5f52f86e8e1da98fbe342988cf35711b26d6 (patch)
tree8a2353031f977104aaacd70fb282a7c3ef69c572 /ext/openssl/extconf.rb
parent9e3cf35690037a2cf74d889c22e7c828e1a036f4 (diff)
* ext/openssl/extconf.rb: should check <openssl/conf_api.h> instead
of OPENSSL_VERSION_NUMBER. [ruby-list:39056] git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_1_8@5515 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'ext/openssl/extconf.rb')
-rw-r--r--ext/openssl/extconf.rb10
1 files changed, 1 insertions, 9 deletions
diff --git a/ext/openssl/extconf.rb b/ext/openssl/extconf.rb
index afcb038..47fa722 100644
--- a/ext/openssl/extconf.rb
+++ b/ext/openssl/extconf.rb
@@ -33,8 +33,6 @@ if with_config("debug") or enable_config("debug")
end
end
-
-
message "=== Checking for system dependent stuff... ===\n"
have_library("nsl", "t_open")
have_library("socket", "socket")
@@ -58,13 +56,7 @@ if !result
end
end
-check_opensslv = <<_end_of_src_
-#include <openssl/opensslv.h>
-#if OPENSSL_VERSION_NUMBER < 0x0090600fL
-# error too old
-#endif
-_end_of_src_
-if !try_compile(check_opensslv)
+unless have_header("openssl/conf_api.h")
message "OpenSSL 0.9.6 or later required.\n"
exit 1
end