summaryrefslogtreecommitdiff
path: root/ext/io/wait
diff options
context:
space:
mode:
authorNobuyoshi Nakada <nobu@ruby-lang.org>2020-09-19 17:26:52 +0900
committerNobuyoshi Nakada <nobu@ruby-lang.org>2020-09-19 17:47:40 +0900
commit73a626c0789161911aa5753859c4a81ed2dfd999 (patch)
treed5d5c5336d504e8118e5c4b485e91c0e70269656 /ext/io/wait
parent702cebf104298b92c67ffd22795d0a4c794dd2f1 (diff)
[ruby/io-wait] update required_ruby_version
As d387029f39d976565c955377117103499d47ff09 made io/wait unbuildable with older versions, drop older versions tentatively. Also the change seems to instroduce behavioral incompatibilities, may address them or bump up the version later.
Diffstat (limited to 'ext/io/wait')
-rw-r--r--ext/io/wait/io-wait.gemspec2
1 files changed, 1 insertions, 1 deletions
diff --git a/ext/io/wait/io-wait.gemspec b/ext/io/wait/io-wait.gemspec
index ca227b6972a..af03215a307 100644
--- a/ext/io/wait/io-wait.gemspec
+++ b/ext/io/wait/io-wait.gemspec
@@ -8,7 +8,7 @@ Gem::Specification.new do |spec|
spec.description = %q{Waits until IO is readable or writable without blocking.}
spec.homepage = "https://github.com/ruby/io-wait"
spec.licenses = ["Ruby", "BSD-2-Clause"]
- spec.required_ruby_version = Gem::Requirement.new(">= 2.3.0")
+ spec.required_ruby_version = Gem::Requirement.new(">= 3.0.0")
spec.metadata["homepage_uri"] = spec.homepage
spec.metadata["source_code_uri"] = spec.homepage