summaryrefslogtreecommitdiff
path: root/ext/gdbm
diff options
context:
space:
mode:
authorLars Kanis <kanis@comcard.de>2019-12-13 10:38:44 +0100
committerHiroshi SHIBATA <hsbt@ruby-lang.org>2021-04-27 20:54:07 +0900
commit22d36c463f5db313a25431150f21c610f4bd6a39 (patch)
treefbc45ecf2fb136f6a2806c2eacaf8dd89ccc5b49 /ext/gdbm
parentad3f4c07d9eb0931d164276471636d04748726f0 (diff)
[ruby/gdbm] Add dependency to gdbm package on mingw
RubyInstaller2 supports metadata tags for installation of dependent MSYS2/MINGW libraries. The openssl gem requires the mingw-openssl package to be installed on the system, which the gem installer takes care about, when this tag is set. The feature is documented here: https://github.com/oneclick/rubyinstaller2/wiki/For-gem-developers#msys2-library-dependency Fixes https://github.com/oneclick/rubyinstaller2/issues/163 https://github.com/ruby/gdbm/commit/d95eed3e86
Diffstat (limited to 'ext/gdbm')
-rw-r--r--ext/gdbm/gdbm.gemspec1
1 files changed, 1 insertions, 0 deletions
diff --git a/ext/gdbm/gdbm.gemspec b/ext/gdbm/gdbm.gemspec
index 6fd42c0..d15d208 100644
--- a/ext/gdbm/gdbm.gemspec
+++ b/ext/gdbm/gdbm.gemspec
@@ -18,4 +18,5 @@ Gem::Specification.new do |spec|
spec.require_paths = ["lib"]
spec.extensions = ["ext/gdbm/extconf.rb"]
spec.required_ruby_version = ">= 2.3.0"
+ spec.metadata["msys2_mingw_dependencies"] = "gdbm"
end