summaryrefslogtreecommitdiff
path: root/ext/gdbm/gdbm.gemspec
diff options
context:
space:
mode:
authorhsbt <hsbt@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2017-04-25 07:55:56 +0000
committerhsbt <hsbt@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2017-04-25 07:55:56 +0000
commit0adeb1c8ab237280896091e9d2034fabf0d050ab (patch)
tree4060c8a49b48d42c128a5223ebb67d93d0ede2fb /ext/gdbm/gdbm.gemspec
parent3c7785451edf608a3e0de89462e3299fe5d83ca3 (diff)
Import gemspec and test file changes from ruby/gdbm.
* gdbm.gemspec: Update basic configuraiton for standalone gdbm gem. * test/gdbm/test_gdbm.rb: In standalone environment, It needs to explicit loading of EnvUtil module for test suite. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@58470 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'ext/gdbm/gdbm.gemspec')
-rw-r--r--ext/gdbm/gdbm.gemspec37
1 files changed, 23 insertions, 14 deletions
diff --git a/ext/gdbm/gdbm.gemspec b/ext/gdbm/gdbm.gemspec
index ace6793..fe4a36c 100644
--- a/ext/gdbm/gdbm.gemspec
+++ b/ext/gdbm/gdbm.gemspec
@@ -1,17 +1,26 @@
-Gem::Specification.new do |s|
- s.name = "gdbm"
- s.version = '0.0.1'
- s.date = '2017-02-24'
- s.summary = "Ruby extension for GNU dbm."
- s.description = "Ruby extension for GNU dbm."
+# coding: utf-8
- s.require_path = %w{lib}
- s.files = %w{depend extconf.rb gdbm.c}
- s.extensions = %w{extconf.rb}
- s.required_ruby_version = ">= 2.5.0dev"
+Gem::Specification.new do |spec|
+ spec.name = "gdbm"
+ spec.version = "0.0.1"
+ spec.date = '2017-02-24'
+ spec.authors = ["Yukihiro Matsumoto"]
+ spec.email = ["matz@ruby-lang.org"]
- s.authors = ["Yukihiro Matsumoto"]
- s.email = ["matz@ruby-lang.org"]
- s.homepage = "https://www.ruby-lang.org"
- s.license = "BSD-2-Clause"
+ spec.summary = "Ruby extension for GNU dbm."
+ spec.description = "Ruby extension for GNU dbm."
+ spec.homepage = "https://github.com/ruby/gdbm"
+ spec.license = "BSD-2-Clause"
+
+ spec.files = ["ext/gdbm/extconf.rb", "ext/gdbm/gdbm.c"]
+ spec.bindir = "exe"
+ spec.executables = spec.files.grep(%r{^exe/}) { |f| File.basename(f) }
+ spec.require_paths = ["lib"]
+ spec.extensions = ["ext/gdbm/extconf.rb"]
+ spec.required_ruby_version = ">= 2.5.0dev"
+
+ spec.add_development_dependency "bundler", "~> 1.14"
+ spec.add_development_dependency "rake", "~> 10.0"
+ spec.add_development_dependency "rake-compiler"
+ spec.add_development_dependency "test-unit"
end