summaryrefslogtreecommitdiff
path: root/ext/etc
diff options
context:
space:
mode:
authorhsbt <hsbt@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2017-04-11 22:41:21 (GMT)
committerhsbt <hsbt@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2017-04-11 22:41:21 (GMT)
commitffa55136c4593c5b5deae64d5f1056302e83419a (patch)
tree75fbd040c25ff9803159f2ce67580b81cd7cd672 /ext/etc
parentabc5e8966ce348fcb96832d8d28416bac4eb151b (diff)
Merge upstream of ruby/etc.
* Do not use `git ls-files` for file listing. * Fix extconf.rb path. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@58321 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'ext/etc')
-rw-r--r--ext/etc/etc.gemspec20
1 files changed, 16 insertions, 4 deletions
diff --git a/ext/etc/etc.gemspec b/ext/etc/etc.gemspec
index f961b67..8a16928 100644
--- a/ext/etc/etc.gemspec
+++ b/ext/etc/etc.gemspec
@@ -12,13 +12,25 @@ Gem::Specification.new do |spec|
spec.homepage = "https://github.com/ruby/etc"
spec.license = "BSD-2-Clause"
- spec.files = `git ls-files -z`.split("\x0").reject do |f|
- f.match(%r{^(test|spec|features)/})
- end
+ spec.files = %w[
+ .gitignore
+ .travis.yml
+ Gemfile
+ LICENSE.txt
+ README.md
+ Rakefile
+ bin/console
+ bin/setup
+ etc.gemspec
+ ext/etc/etc.c
+ ext/etc/extconf.rb
+ ext/etc/mkconstants.rb
+ test/etc/test_etc.rb
+ ]
spec.bindir = "exe"
spec.executables = spec.files.grep(%r{^exe/}) { |f| File.basename(f) }
spec.require_paths = ["lib"]
- spec.extensions = %w{extconf.rb}
+ spec.extensions = %w{ext/etc/extconf.rb}
spec.required_ruby_version = ">= 2.5.0dev"