summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authoreban <eban@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2000-09-19 05:03:07 +0000
committereban <eban@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2000-09-19 05:03:07 +0000
commitc74a3b21f59af9a59e42d42e4947beab3897e208 (patch)
tree0c694a6712fe61bba0858c52015c397aa5ed86c4 /configure.in
parent79a80729109338abe66a4448916e650c4bfbcc9b (diff)
eban
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@944 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 6d35250417..055f42229e 100644
--- a/configure.in
+++ b/configure.in
@@ -849,7 +849,7 @@ case "$target_os" in
esac
;;
cygwin*|mingw*)
- RUBY_SO_NAME='$(RUBY_INSTALL_NAME)'.$target_os
+ RUBY_SO_NAME=$target_os-'$(RUBY_INSTALL_NAME)'-${MAJOR}.${MINOR}
if test x"$enable_shared" = xyes; then
LIBRUBY_SO='$(RUBY_SO_NAME)'.dll
LIBRUBY_DLDFLAGS='--dllname=$@ --output-lib=$(LIBRUBY) --add-stdcall-alias --def=$(RUBYDEF)'