summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2014-12-18 08:45:28 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2014-12-18 08:45:28 +0000
commit9701d08d1f20923f6a96b9a17c190cacde283e65 (patch)
treed484fabd9867339d73a44d86e5ea69fe35c688c0 /configure.in
parenta171f0ea401a6093498d90e5c404cdd99b8c8a22 (diff)
configure.in: fix fox BusyBox
* configure.in (rb_cv_binary_elf): get rid of -e option of cat which is not available on BusyBox, use tr instead. [ruby-core:64824] [Bug #10210] git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@48886 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 5f7ae53153..e132076d65 100644
--- a/configure.in
+++ b/configure.in
@@ -2812,8 +2812,8 @@ AC_ARG_WITH(dln-a-out,
AC_CACHE_CHECK(whether ELF binaries are produced, rb_cv_binary_elf,
[AC_TRY_LINK([],[], [
-AS_CASE(["`head -1 conftest$EXEEXT | cat -e`"],
-['^?ELF'*], [rb_cv_binary_elf=yes], [rb_cv_binary_elf=no])],
+AS_CASE(["`head -1 conftest$EXEEXT | tr -dc '\177ELF' | tr '\177' .`"],
+[.ELF*], [rb_cv_binary_elf=yes], [rb_cv_binary_elf=no])],
rb_cv_binary_elf=no)])
if test "$rb_cv_binary_elf" = yes; then