summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authoreban <eban@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2000-07-25 14:46:46 +0000
committereban <eban@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2000-07-25 14:46:46 +0000
commit94089e82a1276df9d222fba111d4d4763aac144a (patch)
tree44d23afcdc3a16754e3896bcfced816a3f096cd2 /configure.in
parentf8971ef1b1765c804477b518ae80e3b79599dc3f (diff)
eban
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@853 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 9 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 7387fdbfda..f7fa8a9ad6 100644
--- a/configure.in
+++ b/configure.in
@@ -824,9 +824,16 @@ case "$target_os" in
esac
;;
cygwin*|mingw*)
- LIBRUBY_SO='lib$(RUBY_INSTALL_NAME).a'
+ if test x"$enable_shared" = xyes; then
+ LIBRUBY_SO='$(RUBY_INSTALL_NAME)-'$target_os.dll
+ LIBRUBY_DLDFLAGS='--dllname=$@ --output-lib=$(LIBRUBY) --add-stdcall-alias --def=$(RUBYDEF)'
+ else
+ LIBRUBY_SO=nul
+ LIBRUBY_DLDFLAGS='--output-exp=$(RUBY_INSTALL_NAME).exp --dllname=$(RUBY_INSTALL_NAME)$(EXEEXT) --output-lib=$(LIBRUBY) --add-stdcall-alias --def=$(RUBYDEF)'
+ fi
LIBRUBY_ALIASES=''
LIBRUBY_A='lib$(RUBY_INSTALL_NAME)s.a'
+ LIBRUBY='lib$(RUBY_INSTALL_NAME).a'
LIBRUBYARG='-L. -l$(RUBY_INSTALL_NAME)'
FIRSTMAKEFILE=GNUmakefile:cygwin/GNUmakefile.in
case "$target_os" in
@@ -837,7 +844,7 @@ case "$target_os" in
LIBOBJS="$LIBOBJS win32.o"
CFLAGS="-DNT -D__MSVCRT__ $CFLAGS"
CCDLFLAGS=-DIMPORT
- SOLIBS='-lwsock32 -lmsvcrt' ;;
+ SOLIBS='$(LIBS)' ;;
esac
;;
*)