summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authormrkn <mrkn@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2011-09-14 03:40:54 +0000
committermrkn <mrkn@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2011-09-14 03:40:54 +0000
commit9151ed22b360ba3d2bde3b51969a682f9a4a3096 (patch)
tree6f555dbc3b6dc818411b23214bfb23f60023cc38 /configure.in
parentfe3306bf900668034fd9cf9604407c5abe535d0f (diff)
* configure.in: do not use gcc-4.2 as the default compiler.
* NEWS: describe the issue about Xcode. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_1_9_3@33269 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 2 insertions, 11 deletions
diff --git a/configure.in b/configure.in
index f763806b41..6971e1ca38 100644
--- a/configure.in
+++ b/configure.in
@@ -89,21 +89,12 @@ fi
dnl checks for alternative programs
AC_CANONICAL_BUILD
-AS_CASE(["$build_os"],
- [darwin11.*], [
- default_cc=cc-4.2
- default_gcc=gcc-4.2
- ], [
- default_cc=cc
- default_gcc=gcc
- ])
-
AC_ARG_WITH(gcc,
AS_HELP_STRING([--without-gcc], [never use gcc]),
[
AS_CASE([$withval],
- [no], [: ${CC=$default_cc}],
- [yes], [: ${CC=$default_gcc}],
+ [no], [: ${CC=cc],
+ [yes], [: ${CC=gcc],
[CC=$withval])])
dnl If the user switches compilers, we can't believe the cache
if test ! -z "$ac_cv_prog_CC" -a ! -z "$CC" -a "$CC" != "$ac_cv_prog_CC"