summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2011-04-26 22:42:46 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2011-04-26 22:42:46 +0000
commit86ed9661b8ac2a1a01f87b72da11a75ad6d7aab7 (patch)
tree7af082440b31bdc029cb1d0a51236bbb1698a3a1 /configure.in
parentdfb52b729b47b78bf326f82b393ae73dcef96f68 (diff)
* configure.in (STRIP): use proper toolchain. based on a patch
from Jon Forums at [ruby-core:35909]. fixes #4617 git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@31365 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 3 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 551306b328..5692eb150e 100644
--- a/configure.in
+++ b/configure.in
@@ -2136,18 +2136,17 @@ test ".$DLEXT" = "." || AC_DEFINE_UNQUOTED(DLEXT, ".$DLEXT")
test ".$DLEXT2" = "." || AC_DEFINE_UNQUOTED(DLEXT2, ".$DLEXT2")
AC_SUBST(DLEXT)
-AC_SUBST(STRIP)dnl
if test "$with_dln_a_out" = yes; then
STRIP=true
else
- STRIP=strip
+ AC_CHECK_TOOL(STRIP, strip, :)dnl
fi
AS_CASE(["$target_os"],
[linux* | gnu* | k*bsd*-gnu | kopensolaris*-gnu], [
- STRIP='strip -S -x'],
+ STRIP="$STRIP -S -x"],
[nextstep* | openstep* | rhapsody* | darwin*], [
- STRIP='strip -A -n'])
+ STRIP="$STRIP -A -n"])
AC_ARG_WITH(ext,
AC_HELP_STRING([--with-ext=EXTS],