summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2014-10-20 03:42:38 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2014-10-20 03:42:38 +0000
commit80de9591c945891ce736e34711491a87b003d76a (patch)
treebfb5358cffbc10796ce0b097ecc389142e76be14 /configure.in
parent0fe805125287d40bb254a7bd8cb15940dc8ca5f4 (diff)
configure.in: downloader needs BASERUBY
* configure.in: try downloader only if BASERUBY is working. use tarballs to build without BASERUBY. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@48040 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 1 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 9ebe009489..3a0d9971cb 100644
--- a/configure.in
+++ b/configure.in
@@ -45,13 +45,12 @@ if test "`RUBYOPT=- $BASERUBY -e 'p 42' 2>/dev/null`" = 42; then
if test "`RUBYOPT=- $BASERUBY --disable=gems -e 'p 42' 2>/dev/null`" = 42; then
BASERUBY="$BASERUBY --disable=gems"
fi
+ $BASERUBY -C "$srcdir/tool" downloader.rb -e gnu config.guess config.sub
else
BASERUBY="echo executable host ruby is required. use --with-baseruby option.; false"
fi
AC_SUBST(BASERUBY)
-$BASERUBY -C "$srcdir/tool" downloader.rb -e gnu config.guess config.sub
-
AC_DEFUN([RUBY_MINGW32],
[AS_CASE(["$host_os"],
[cygwin*], [