summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-01-19 08:24:10 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-01-19 08:24:10 +0000
commit49e685a0af54f3916542b4720da9b7e3f92e347d (patch)
tree34f2db4769ba67c0907313fcdfdb6824722a6bee /configure.in
parentc872df9e285eeb6aa3a57ce3b91f70df1c2e34da (diff)
* include/ruby/defines.h (RUBY_ALIAS_FUNCTION2): added.
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@21665 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 5 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index 264903ea3f..6f5a33695b 100644
--- a/configure.in
+++ b/configure.in
@@ -472,12 +472,11 @@ if test "$GCC" = yes; then
void bar(void) __attribute__(($a("foo")));], [bar()],
[rb_cv_gcc_function_alias=$a; break])
done])
- if test "$rb_cv_gcc_function_alias" = no; then
- AC_DEFINE([RUBY_ALIAS_FUNCTION(old_prot, new_name, args)],
- [VALUE old_prot {return new_name args;}])
- else
- AC_DEFINE_UNQUOTED([RUBY_ALIAS_FUNCTION(old_prot, new_name, args)],
- [VALUE old_prot __attribute__(($rb_cv_gcc_function_alias(@%:@new_name)));])
+ if test "$rb_cv_gcc_function_alias" != no; then
+ AC_DEFINE_UNQUOTED([RUBY_ALIAS_FUNCTION2(type, prot, name, args)],
+ [type prot __attribute__(($rb_cv_gcc_function_alias(@%:@name)));])
+ AC_DEFINE_UNQUOTED([RUBY_ALIAS_FUNCTION_VOID(prot, name, args)],
+ [RUBY_ALIAS_FUNCTION2(void, prot, name, args)])
fi
fi