summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2008-06-21 06:54:58 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2008-06-21 06:54:58 +0000
commit3d9c550bf91da943f196e71c821953c20ca601dd (patch)
treef3c99430494b9cd63d979430681a275feffc69ba /configure.in
parent7ae9072fdf5856abb3197e08dac030bbcb5cad52 (diff)
* configure.in: check if fork works with pthread.
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@17496 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in58
1 files changed, 58 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index c15d747bcc..da8518f440 100644
--- a/configure.in
+++ b/configure.in
@@ -766,6 +766,64 @@ AC_DEFINE_UNQUOTED([RUBY_SETJMP(env)], [${setjmp_prefix}setjmp(env${setjmp_sigma
AC_DEFINE_UNQUOTED([RUBY_LONGJMP(env,val)], [${setjmp_prefix}longjmp(env,val)])
AC_DEFINE_UNQUOTED(RUBY_JMP_BUF, ${setjmp_sigmask+${setjmp_prefix}}jmp_buf)
+
+case $target_os in
+*bsd*|darwin*)
+AC_CACHE_CHECK([if fork works with pthread], rb_cv_fork_with_pthread,
+[AC_TRY_RUN([
+#include <stdlib.h>
+#include <unistd.h>
+#include <pthread.h>
+#include <stdio.h>
+#include <sys/types.h>
+#include <sys/wait.h>
+#include <signal.h>
+
+void *
+thread_func(void *dmy)
+{
+ return dmy;
+}
+
+void *use_threads(void)
+{
+ pthread_t tid;
+ if (pthread_create(&tid, 0, thread_func, 0) != 0) {
+ exit(1);
+ }
+ if (pthread_join(tid, 0) != 0) {
+ exit(1);
+ }
+}
+
+int
+main(int argc, char *argv[])
+{
+ pid_t pid;
+ use_threads();
+ pid = fork();
+
+ if (pid) {
+ int loc;
+ sleep(1);
+ if (waitpid(pid, &loc, WNOHANG) == 0) {
+ kill(pid, SIGKILL);
+ return 1;
+ }
+ }
+ else {
+ use_threads();
+ }
+
+ return 0;
+}]
+ rb_cv_fork_with_pthread=yes,
+ rb_cv_fork_with_pthread=no,
+ rb_cv_fork_with_pthread=yes)])
+ ;;
+esac
+test x$rb_cv_fork_with_pthread = xyes || AC_DEFINE(CANNOT_FORK_WITH_PTHREAD)
+
AC_ARG_ENABLE(setreuid,
[ --enable-setreuid use setreuid()/setregid() according to need even if obsolete.],
[use_setreuid=$enableval])