summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2013-04-01 05:41:27 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2013-04-01 05:41:27 +0000
commit39626559944ac960b21cc1ce3c740a0ab61b1648 (patch)
tree4092f83d8cfc951868574c3d9308220218f45c00 /configure.in
parent90e8a9b4bd583d7b65edf97343dd7d8317f091a6 (diff)
configure.in: clang check
* configure.in: should not use AC_COMPILE_IFELSE before AC_USE_SYSTEM_EXTENSIONS. [Bug #8192] git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@40031 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 5 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 3a9a14aa42..4c1d7353d4 100644
--- a/configure.in
+++ b/configure.in
@@ -396,12 +396,13 @@ AS_CASE(["$host_os:$build_os"],
# clang version 1.0 (http://llvm.org/svn/llvm-project/cfe/tags/Apple/clang-23 exported)
# Apple clang version 2.0 (tags/Apple/clang-137) (based on LLVM 2.9svn)
# Apple clang version 2.1 (tags/Apple/clang-163.7.1) (based on LLVM 3.0svn)
- AC_COMPILE_IFELSE([AC_LANG_PROGRAM([
+ if ! $CC -E -xc - <<SRC >/dev/null; then
@%:@if defined __APPLE_CC__ && defined __clang_major__ && __clang_major__ < 3
@%:@error premature clang
- @%:@endif])],
- [],
- [AC_MSG_ERROR([clang version 3.0 or later is required])])
+ @%:@endif
+SRC
+ AC_MSG_ERROR([clang version 3.0 or later is required])
+ fi
])
if test x"${build}" != x"${host}"; then
AC_CHECK_TOOL(CC, gcc)