summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2014-11-27 20:10:26 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2014-11-27 20:10:26 +0000
commit38f3708fc1b3dd9de4ccaf1ec52ffeee996dd847 (patch)
treedba83b33b2ab9b14e71c36cb14469b3b0e43bb76 /configure.in
parente5df8e7bb39129b3bd6db9dc5ba8567f6a0190ab (diff)
configure.in: add --with-setup option
* configure.in (--with-setup): add option to select ext/Setup file. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@48625 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 7b29193e59..d0f22706aa 100644
--- a/configure.in
+++ b/configure.in
@@ -3247,7 +3247,14 @@ AS_CASE([",$EXTSTATIC,"], [,static,|*,enc,*], [
AC_SUBST(ENCOBJS)
AC_SUBST(EXTOBJS)
-if test -f "$srcdir/ext/Setup.$target_os"; then
+AC_ARG_WITH(setup,
+ AS_HELP_STRING([--with-setup=SETUP], [use extension libraries setup]),
+ [setup=$withval])
+if test -n "$setup"; then
+ if ! test -f "ext/$setup" -o -f "$srcdir/ext/$setup"; then
+ AC_MSG_ERROR(Setup file $setup not found under ext or $srcdir/ext)
+ fi
+elif test -f "$srcdir/ext/Setup.$target_os"; then
setup="Setup.$target_os"
else
setup=