summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authoreban <eban@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2001-11-30 09:17:30 +0000
committereban <eban@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2001-11-30 09:17:30 +0000
commit3691d88f3630ab0eb3ecfb77a1f3ac416b43380e (patch)
tree2d18ddaf3b2d6f250ae6491c8b36a77ff2e9cb04 /configure.in
parentbe020d6c05157df3d1d3a35abf7dce727a6d5dac (diff)
* configure.in: set target_cpu to i386 on cygwin and mingw32.
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@1866 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 83a90037d9..46155c3ec5 100644
--- a/configure.in
+++ b/configure.in
@@ -111,6 +111,8 @@ cygwin*|mingw*)
AC_CHECK_TOOL(AS, as)
AC_CHECK_TOOL(DLLTOOL, dlltool)
AC_CHECK_TOOL(WINDRES, windres)
+ target_cpu=`echo $target_cpu | sed s/i.86/i386/`
+ : ${enable_shared=yes}
;;
esac
@@ -856,7 +858,7 @@ LIBRUBY_SO='lib$(RUBY_INSTALL_NAME).so.$(MAJOR).$(MINOR).$(TEENY)'
LIBRUBY_ALIASES='lib$(RUBY_INSTALL_NAME).so'
ENABLE_SHARED=no
-AC_ARG_ENABLE(enable-shared,
+AC_ARG_ENABLE(shared,
[--enable-shared build a shared library for Ruby. ],
[enable_shared=$enableval])
if test "$enable_shared" = 'yes'; then