summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2011-03-08 00:07:19 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2011-03-08 00:07:19 +0000
commit108eb9c68c00d43eb33b20341dee8506717d4a3d (patch)
treea8f6edff660a401fab72636eeaa413d696995f96 /configure.in
parentc57118f757619042261c65098a7001a05addf4de (diff)
* configure.in (RUBY_REPLACE_TYPE): enclose in quotes for multiple
type names. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@31056 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index b551d67947..62ba73fa38 100644
--- a/configure.in
+++ b/configure.in
@@ -642,7 +642,10 @@ fi
dnl RUBY_REPLACE_TYPE [typename] [default type] [macro type] [included]
AC_DEFUN([RUBY_REPLACE_TYPE], [dnl
- AC_CHECK_TYPE([$1], [n=[$1]], [n=[$2]], [$4])
+ AC_CHECK_TYPE([$1],
+ [n="patsubst([$1],["],[\\"])"],
+ [n="patsubst([$2],["],[\\"])"],
+ [$4])
AC_CACHE_CHECK([for convertible type of [$1]], rb_cv_[$1]_convertible, [
u= t=
AS_CASE(["$n "],