summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authormatz <matz@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>1998-06-16 04:24:38 +0000
committermatz <matz@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>1998-06-16 04:24:38 +0000
commit16487ee284f17cfbf6fad9f6b2fedc57f0f37e0a (patch)
tree0c0aab325ab782ff559d1cfa5df269e786219ee3 /configure.in
parent83687c4eb47e2bcbe463d097317d068d1dd0b734 (diff)
baseline
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/v1_1r@243 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in48
1 files changed, 41 insertions, 7 deletions
diff --git a/configure.in b/configure.in
index 946f4b876a..c8f534d556 100644
--- a/configure.in
+++ b/configure.in
@@ -33,17 +33,25 @@ AC_CANONICAL_HOST
dnl checks for fat-binary
fat_binary=no
AC_ARG_ENABLE( fat-binary,
- [--enable-fat-binary build a NeXT Multi Architecture Binary. ],
+ [--enable-fat-binary build a NeXT/Apple Multi Architecture Binary. ],
[ fat_binary=$enableval ] )
-if test "$fat_binary" = yes ; then
+ if test "$fat_binary" = yes ; then
AC_MSG_CHECKING( target architecture )
- if test "$TARGET_ARCHS" = "" ; then
- if test `/usr/bin/arch` = "m68k" ; then
- TARGET_ARCHS="m68k i486"
- else
- TARGET_ARCHS="m68k `/usr/bin/arch`"
+ if test "$host_os" = "rhapsody" ; then
+ echo -n "Rhapsody: "
+ if test "$TARGET_ARCHS" = "" ; then
+ TARGET_ARCHS="ppc i486"
+ fi
+ else
+ echo -n "NeXTSTEP/OPENSTEP: "
+ if test "$TARGET_ARCHS" = "" ; then
+ if test `/usr/bin/arch` = "m68k" ; then
+ TARGET_ARCHS="m68k i486"
+ else
+ TARGET_ARCHS="m68k `/usr/bin/arch`"
+ fi
fi
fi
# /usr/lib/arch_tool -archify_list $TARGET_ARCHS
@@ -118,6 +126,8 @@ fi
dnl Checks for libraries.
case "$host_os" in
nextstep*) ;;
+openstep*) ;;
+rhapsody*) ;;
human*) ;;
beos*) ;;
*) LIBS="-lm $LIBS";;
@@ -312,6 +322,8 @@ if test "$with_dln_a_out" != yes; then
if test "$GCC" = yes; then
case "$host_os" in
nextstep*) ;;
+ openstep*) ;;
+ rhapsody*) ;;
human*) ;;
*) CCDLFLAGS=-fpic;;
esac
@@ -352,6 +364,14 @@ if test "$with_dln_a_out" != yes; then
LDFLAGS="-u libsys_s"
DLDFLAGS="$ARCH_FLAG"
rb_cv_dlopen=yes ;;
+ openstep*) LDSHARED='cc -dynamic -bundle -undefined suppress'
+ LDFLAGS=""
+ DLDFLAGS="$ARCH_FLAG"
+ rb_cv_dlopen=yes ;;
+ rhapsody*) LDSHARED='cc -dynamic -bundle -undefined suppress'
+ LDFLAGS=""
+ DLDFLAGS="$ARCH_FLAG"
+ rb_cv_dlopen=yes ;;
aix*) LDSHARED='../../miniruby ../aix_ld.rb $(TARGET)'
rb_cv_dlopen=yes ;;
human*) DLDFLAGS=''
@@ -408,6 +428,10 @@ else
AC_DEFINE(DLEXT, ".sl");;
nextstep*) DLEXT=o
AC_DEFINE(DLEXT, ".o");;
+ openstep*) DLEXT=bundle
+ AC_DEFINE(DLEXT, ".bundle");;
+ rhapsody*) DLEXT=bundle
+ AC_DEFINE(DLEXT, ".bundle");;
*) DLEXT=so
AC_DEFINE(DLEXT, ".so");;
esac
@@ -425,6 +449,10 @@ case "$host_os" in
STRIP='strip -S -x';;
nextstep*)
STRIP='strip -A -n';;
+ openstep*)
+ STRIP='strip -A -n';;
+ rhapsody*)
+ STRIP='strip -A -n';;
esac
EXTSTATIC=
@@ -521,6 +549,12 @@ if test "$host_os" = "beos"; then
;;
esac
fi
+
+if test "$host_os" = "rhapsody" ; then
+ CFLAGS="$CFLAGS -no-precomp"
+fi
+
+
AC_SUBST(LIBRUBY)
AC_SUBST(LIBRUBYARG)
AC_SUBST(SOLIBS)