summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authormatz <matz@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>1999-02-15 07:31:51 +0000
committermatz <matz@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>1999-02-15 07:31:51 +0000
commit51fa86ece2d2b0f72c86c70fe1314e412c7a9e68 (patch)
tree86cdfce906bcc995c55e83a907f9d9f7be071da0 /configure.in
parent42c802126215101feed36135ba8f9601895ec03a (diff)
990215
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_1_3@402 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in26
1 files changed, 4 insertions, 22 deletions
diff --git a/configure.in b/configure.in
index 069cffba8e..26945dd0d9 100644
--- a/configure.in
+++ b/configure.in
@@ -230,26 +230,8 @@ main()
fi
fi
-if test "$ac_cv_func_setpgrp2" = yes; then
- AC_DEFINE(BSD_GETPGRP, getpgrp2)
- AC_DEFINE(BSD_SETPGRP, setpgrp2)
-else
- AC_CACHE_CHECK(whether getpgrp() has arg, rb_cv_bsdgetpgrp,
- [AC_TRY_COMPILE([#include <unistd.h>], [getpgrp(0);],
- rb_cv_bsdgetpgrp=yes,
- rb_cv_bsdgetpgrp=no)])
- if test "$rb_cv_bsdgetpgrp" = yes; then
- AC_DEFINE(BSD_GETPGRP, getpgrp)
- fi
-
- AC_CACHE_CHECK(whether setpgrp() has args, rb_cv_bsdsetpgrp,
- [AC_TRY_COMPILE([#include <unistd.h>], [setpgrp(1, 1);],
- rb_cv_bsdsetpgrp=yes,
- rb_cv_bsdsetpgrp=no)])
- if test "$rb_cv_bsdsetpgrp" = yes; then
- AC_DEFINE(BSD_SETPGRP, setpgrp)
- fi
-fi
+AC_FUNC_GETPGRP
+AC_FUNC_SETPGRP
AC_CACHE_CHECK(for working strtod, rb_cv_func_strtod,
[AC_TRY_RUN([
@@ -402,7 +384,7 @@ if test "$with_dln_a_out" != yes; then
LDFLAGS="-Wl,-E"
rb_cv_dlopen=yes;;
solaris*) LDSHARED='ld -G'
- LDFLAGS="-Wl,-E"
+ test "$GCC" = yes && `$CC --print-prog-name=ld` -v 2>&1 | grep "GNU ld" > /dev/null && LDFLAGS="-Wl,-E"
rb_cv_dlopen=yes;;
sunos*) LDSHARED='ld -assert nodefinitions'
rb_cv_dlopen=yes;;
@@ -681,7 +663,7 @@ ri_prefix=
test "$program_prefix" != NONE &&
ri_prefix=$program_prefix
-ri_suffix="${MAJOR}.${MINOR}"
+ri_suffix=
test "$program_suffix" != NONE &&
ri_suffix=$program_suffix