summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNobuyoshi Nakada <nobu@ruby-lang.org>2021-11-30 11:12:21 +0900
committerNobuyoshi Nakada <nobu@ruby-lang.org>2021-11-30 11:12:21 +0900
commitf379748e80dacc208dbe23a2db508aead8b79978 (patch)
tree3c1fdbf0eb62ce475c5ec544b0bea98e504849e0 /configure.ac
parent12fbdf4d4e52bafaeef6f923b8f357a39a37c02b (diff)
Cache wheather madvise declaration is needed on Solaris
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 7ec11478f5..a3e97d54db 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1108,15 +1108,18 @@ main()
])
])
AC_CHECK_TYPES([caddr_t],[],[],[@%:@include <sys/types.h>])
- RUBY_WERROR_FLAG([AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
+ AC_CACHE_CHECK([whether madvise declaration is needed], rb_cv_madvice_prototype_using_caddr_t,
+ [RUBY_WERROR_FLAG([AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
@%:@if defined(HAVE_CADDR_T) && (defined(MADV_FREE) || defined(MADV_DONTNEED))
@%:@include <sys/unistd.h>
@%:@include <sys/mman.h>
@%:@include <sys/types.h>
extern int madvise(caddr_t, size_t, int);
]], [[]])],
- [AC_DEFINE(NEED_MADVICE_PROTOTYPE_USING_CADDR_T, 1)], [])
+ [rb_cv_madvice_prototype_using_caddr_t=yes], [rb_cv_madvice_prototype_using_caddr_t=no])
+ ])
])
+ AS_IF([test $rb_cv_madvice_prototype_using_caddr_t = yes], [AC_DEFINE(NEED_MADVICE_PROTOTYPE_USING_CADDR_T, 1)])
],
[haiku*], [
LIBS="$LIBS" # m lib is include in root