summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNobuyoshi Nakada <nobu@ruby-lang.org>2021-12-07 12:32:02 +0900
committerNobuyoshi Nakada <nobu@ruby-lang.org>2021-12-07 15:20:02 +0900
commitec878dac90df0ca5f39e72261b8d4e2898486a93 (patch)
treeb5f6683464626083d0d31125c2cd13648d2e5898 /configure.ac
parent91e9d27629dbea71248868ed98f4b4e8796b81b1 (diff)
Move -ljemalloc to DLDLIBS [Bug #18391]
Set the alternative memory management library only as a platform specific library, without other libraries.
Notes
Notes: Merged: https://github.com/ruby/ruby/pull/5223
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 0f7c0d5477..7177d5bb8e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1363,6 +1363,7 @@ AS_IF([test "x$with_jemalloc" != xno],[
[-l*], [
set dummy $with_jemalloc
LIBS="$2 $LIBS"
+ DLDLIBS="$2${DLDLIBS:+ $DLDLIBS}" # probably needed also in extension libraries
])
AS_CASE(["$with_jemalloc"],
[*" with mangle"], [
@@ -3353,7 +3354,7 @@ AS_CASE(["$target_os"],
: ${DLDLIBS=""}
],
[
- DLDLIBS="$DLDLIBS -lc"
+ DLDLIBS="${DLDLIBS:+$DLDLIBS }-lc"
])
AC_ARG_ENABLE(multiarch,
@@ -3898,7 +3899,6 @@ AS_IF([test -n "${LIBS}"], [
MAINFLAGS=`echo " $MAINLIBS " | sed "s|$libspat"'||;s/^ *//;s/ *$//'`
])
LIBRUBYARG_STATIC="${LIBRUBYARG_STATIC} \$(MAINLIBS)"
-LIBRUBYARG_SHARED="${LIBRUBYARG_SHARED} \$(MAINLIBS)"
CPPFLAGS="$CPPFLAGS "'$(DEFS)'
test -z "$CPPFLAGS" || CPPFLAGS="$CPPFLAGS "; CPPFLAGS="$CPPFLAGS"'${cppflags}'
AS_IF([test -n "${cflags+set}"], [