summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Wu <XrXr@users.noreply.github.com>2023-01-12 17:07:00 -0500
committerAlan Wu <XrXr@users.noreply.github.com>2023-01-27 12:28:09 -0500
commite7e48e8a667614c8264993c746ad84b92de997fd (patch)
tree050e3b71d038e4b3b50183e6524b7b830907e9f8 /configure.ac
parent17c8bf2c63192036058b03a04edf7a8478e47833 (diff)
configure: Keep OBJCOPY even when visibility options are available
YJIT will need it to address symbol leakage issue. Fallback to `:` when OBJCOPY is not available on the system. Co-authored-by: Co-authored-by: Nobuyoshi Nakada <nobu@ruby-lang.org>
Notes
Notes: Merged: https://github.com/ruby/ruby/pull/7115
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 1 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 652a1fc153..ec8a6f4c09 100644
--- a/configure.ac
+++ b/configure.ac
@@ -254,7 +254,7 @@ AC_CHECK_TOOLS([AR], [gar ar])
AC_CHECK_TOOLS([AS], [gas as])
AC_CHECK_TOOLS([LD], [gld ld]) # ... try gold ?
AC_CHECK_TOOLS([NM], [gnm nm])
-AC_CHECK_TOOLS([OBJCOPY], [gobjcopy objcopy])
+AC_CHECK_TOOLS([OBJCOPY], [gobjcopy objcopy], [:])
AC_CHECK_TOOLS([OBJDUMP], [gobjdump objdump])
AC_CHECK_TOOLS([STRIP], [gstrip strip], [:])
@@ -907,7 +907,6 @@ AS_IF([test "$GCC" = yes], [
], [
RUBY_TRY_LDFLAGS([-Wl,-unexported_symbol,_Init_*], [visibility_option=ld], [visibility_option=no])
])
- test "$visibility_option" = no || OBJCOPY=:
])
AS_IF([test "$GCC" = yes], [