summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Carlier <devnexen@gmail.com>2021-02-14 16:01:00 +0000
committerNobuyoshi Nakada <nobu@ruby-lang.org>2021-02-15 17:16:14 +0900
commitdfd029c9627b96f5bfc7ece2b61d5019131d83b2 (patch)
tree06039478ae1ef6cd8345a6c53dad00cd49b9e8ad /configure.ac
parent2947ae3254c49e7861f29138df0b378fc81af14d (diff)
supports for stack protection for haiku.
Notes
Notes: Merged: https://github.com/ruby/ruby/pull/4186
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 87a13758f2..41f2879645 100644
--- a/configure.ac
+++ b/configure.ac
@@ -684,7 +684,7 @@ AS_IF([test "$GCC" = yes], [
# -fstack-protector
AS_CASE(["$target_os"],
- [mingw*|haiku*|emscripten*], [
+ [mingw*|emscripten*], [
stack_protector=no
])
AS_IF([test -z "${stack_protector+set}"], [
@@ -1050,7 +1050,7 @@ main()
])
],
[haiku*], [
- LIBS="$LIBS" # m lib is include in root
+ LIBS="$LIBS -lssp" # m lib is include in root
],
[cygwin*|msys*], [
ac_cv_header_langinfo_h=yes