summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJeremy Evans <code@jeremyevans.net>2019-06-26 07:53:54 -0700
committerJeremy Evans <code@jeremyevans.net>2019-06-26 07:53:54 -0700
commitd004989ac6355bcf2840ed190aae139c3a852848 (patch)
treef107dc6c3ca6b865eced0952f6870814f83539ba /configure.ac
parent1235e054eb100fcd75f03d2f22dbbd4952bbaf31 (diff)
Do not attempt to use ucontext for fibers on OpenBSD
OpenBSD does not support ucontext. There may be a more generic way to handle this, using the result of AC_CHECK_HEADERS(ucontext.h).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e5dc01abe7..bba8f61b0e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2281,6 +2281,9 @@ AS_CASE(["$rb_cv_fiber_coroutine"], [yes|''], [
[powerpc64le-linux], [
rb_cv_fiber_coroutine=ppc64le
],
+ [*-openbsd*], [
+ rb_cv_fiber_coroutine=
+ ],
[*], [
rb_cv_fiber_coroutine=ucontext
]