summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2018-10-03 06:48:35 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2018-10-03 06:48:35 +0000
commitb68f2a4bba4ca8cf94aba5dc691c88b93901606a (patch)
tree41dbce3cccdadec46b2d1e98f87da52207525c7e /configure.ac
parent1af64187420d4aa5cd7955041a582bbdadcf8f42 (diff)
Use cd -P
Setting PWD in the process does not let `cd` traverse symlinks in /bin/sh on macOS. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@64906 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index fb7c5c97d8..df1ef8cf2e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -262,7 +262,7 @@ AS_CASE(["$build_os"],
@%:@error ignore linker warnings
@%:@endif
SRC
- CC_WRAPPER=`PWD=; cd "$srcdir/tool" && pwd`/darwin-cc
+ CC_WRAPPER=`cd -P "$srcdir/tool" && pwd`/darwin-cc
CC="$CC_WRAPPER $CC"
])
])