summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorsamuel <samuel@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2018-11-20 10:17:31 +0000
committersamuel <samuel@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2018-11-20 10:17:31 +0000
commit43d7fd0946020157b4c3c8e124b3bf9a17d9789a (patch)
tree55c9e0ee7e937ded7561ba23c68dfbb9ad270a57 /configure.ac
parent98e26e962df00414e386b02366d650cafc036cde (diff)
Limit coroutine implementations to Linux.
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@65865 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 3ae62e9d31..f6b0bf010e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2327,13 +2327,13 @@ AS_IF([test "${universal_binary-no}" = yes ], [
AC_MSG_CHECKING(native fiber implementation)
AS_CASE(["$target_cpu-$target_os"],
- [x*64-*], [
+ [x*64-*x], [
AC_MSG_RESULT(amd64)
COROUTINE_H=coroutine/amd64/Context.h
AC_DEFINE_UNQUOTED(FIBER_USE_COROUTINE, ["$COROUTINE_H"])
AC_LIBOBJ([coroutine/amd64/Context])
],
- [*86-*], [
+ [*86-*x], [
AC_MSG_RESULT(x86)
COROUTINE_H=coroutine/x86/Context.h
AC_DEFINE_UNQUOTED(FIBER_USE_COROUTINE, ["$COROUTINE_H"])