summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKoichi Sasada <ko1@atdot.net>2019-12-10 17:39:04 +0900
committerKoichi Sasada <ko1@atdot.net>2019-12-11 11:24:42 +0900
commit40026a408df5e3576380f6c1d8bf6c119fa2e32b (patch)
tree5946811b38d5b70aaa0c5a4ab983fef19478ded9 /configure.ac
parent9c2807b2df14984e3c81d72a381d9a4d288b3fbe (diff)
support cross-compilation.
On cross-compilation, compiled binary can no be created because compiled binary should be created by same interpreter (on cross- compilation, host ruby is used to build ruby (BASERUBY)). So that cross-compilation system loads required scripts in text. It is same as miniruby.
Notes
Notes: Merged: https://github.com/ruby/ruby/pull/2735
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6cea43d0c9..83d6ff4e23 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3053,6 +3053,7 @@ AS_IF([test x"$cross_compiling" = xyes], [
XRUBY='$(MINIRUBY)'
TEST_RUNNABLE=no
CROSS_COMPILING=yes
+ AC_DEFINE(CROSS_COMPILING, 1)
], [
MINIRUBY='./miniruby$(EXEEXT) -I$(srcdir)/lib -I.'
MINIRUBY="$MINIRUBY"' -I$(EXTOUT)/common'