summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTakashi Kokubun <takashikkbn@gmail.com>2022-11-20 23:21:28 -0800
committerTakashi Kokubun <takashikkbn@gmail.com>2022-11-20 23:21:28 -0800
commit3071a727e081f754e71a9abed8dd19e36bacc785 (patch)
tree06bd6018d1ee65b42440f2020f89eeb513b2ea2d /configure.ac
parent730b841f8d6ba76d793a608cc20f46684a7d2cb1 (diff)
Add a comment about confusing code [ci skip]
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d11aae2170..4e118b7813 100644
--- a/configure.ac
+++ b/configure.ac
@@ -64,6 +64,7 @@ AC_ARG_WITH(baseruby,
[
AC_PATH_PROG([BASERUBY], [ruby], [false])
])
+# BASERUBY must be >= 2.2.0. Note that `"2.2.0" > "2.2"` is true.
AS_IF([test "$HAVE_BASERUBY" != no -a "`RUBYOPT=- $BASERUBY --disable=gems -e 'print 42 if RUBY_VERSION > "2.2"' 2>/dev/null`" = 42], [
AS_CASE(["$build_os"], [mingw*], [
# Can MSys shell run a command with a drive letter?