summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNobuyoshi Nakada <nobu@ruby-lang.org>2021-01-27 14:50:27 +0900
committerNobuyoshi Nakada <nobu@ruby-lang.org>2021-01-27 14:50:27 +0900
commit0d5a4d6d4973af3dfbdb19c965efe6c86dbdd8ad (patch)
treec6f95cc46c9b2674b36669981656605984d944c8 /configure.ac
parentb409a34b410e748553262cb4d0c9cc374746dfd8 (diff)
Disable fast-math
As `RUBY_TRY_CFLAGS` restores `CFLAGS`, appending to the variable in its block has no effect.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 285a2f9bcd..371cbf3da0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -813,7 +813,7 @@ AS_IF([test "$GCC" = yes], [
# disable fast-math
for oflag in -fno-fast-math; do
- RUBY_TRY_CFLAGS($oflag, [RUBY_APPEND_OPTION(CFLAGS, $oflag)])
+ RUBY_TRY_CFLAGS($oflag, [RUBY_APPEND_OPTION(optflags, $oflag)])
done
for oflag in -fexcess-precision=standard -fp-model\ precise; do
RUBY_TRY_CFLAGS($oflag, [RUBY_APPEND_OPTION(XCFLAGS, $oflag)])