summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorsamuel <samuel@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2018-11-20 10:17:44 +0000
committersamuel <samuel@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2018-11-20 10:17:44 +0000
commit0b5e1442f5425490f9c9d249683d05fe72b29ea9 (patch)
tree3f5601767fcc34fd5b8b4560c2d7e3b436fef6e5 /configure.ac
parentd97c9280671444215da845bb71c2d624a08be4df (diff)
Initial support for x64-mingw32
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@65868 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 13 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 4d74c7737e..4dec975960 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2325,8 +2325,14 @@ AS_IF([test "${universal_binary-no}" = yes ], [
AC_DEFINE_UNQUOTED(STACK_GROW_DIRECTION, $dir)
])
-AC_MSG_CHECKING(native fiber implementation)
+AC_MSG_CHECKING(native coroutine implementation for $target_cpu-$target_os)
AS_CASE(["$target_cpu-$target_os"],
+ [x*64-darwin], [
+ AC_MSG_RESULT(amd64)
+ COROUTINE_H=coroutine/amd64/Context.h
+ AC_DEFINE_UNQUOTED(FIBER_USE_COROUTINE, ["$COROUTINE_H"])
+ AC_LIBOBJ([coroutine/amd64/Context])
+ ],
[x*64-linux], [
AC_MSG_RESULT(amd64)
COROUTINE_H=coroutine/amd64/Context.h
@@ -2339,6 +2345,12 @@ AS_CASE(["$target_cpu-$target_os"],
AC_DEFINE_UNQUOTED(FIBER_USE_COROUTINE, ["$COROUTINE_H"])
AC_LIBOBJ([coroutine/x86/Context])
]
+ [x64-mingw32], [
+ AC_MSG_RESULT(x86)
+ COROUTINE_H=coroutine/win64/Context.h
+ AC_DEFINE_UNQUOTED(FIBER_USE_COROUTINE, ["$COROUTINE_H"])
+ AC_LIBOBJ([coroutine/win64/Context])
+ ]
[*], [
AC_MSG_RESULT(no)
]