summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJun Aruga <jaruga@redhat.com>2022-04-21 22:59:59 +0200
committerJun Aruga <junaruga@users.noreply.github.com>2022-05-12 12:36:10 +0200
commit019cbded90ade76fdb87d02bd4d444724429fc92 (patch)
tree1ebfe628e0fc5e3d30fd13efbf3868b9a124fd3e /configure.ac
parent40ca208a6db8d3a53cc016caab2aa8301bafdac2 (diff)
mkmf: Add a configure option to set verbose mode (V=1 or 0) in mkmf.rb.
Note this change is only for `configure.ac`, not for Windows using `win32/configure.bat`. ``` $ ./configure --help | grep mkmf --enable-mkmf-verbose enable verbose in mkmf ``` Run the following command to enable the mkmf verbose mode. ``` $ ./configure --enable-mkmf-verbose $ grep MKMF_VERBOSE config.status S["MKMF_VERBOSE"]="1" ``` In this mkmf verbose mode, when compiling a native extension, the `rake compile` prints the compiling commands such as "gcc -I. <...> path/to/file" instead of "compiling path/to/file". ``` $ git clone https://github.com/deivid-rodriguez/byebug.git $ cd byebug $ bundle install --standalone $ bundle exec rake compile ... gcc -I. <...> path/to/file ... ```
Notes
Notes: Merged: https://github.com/ruby/ruby/pull/5879
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2b25d7b069..53aa21025e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4227,6 +4227,13 @@ AS_IF([test -z "$MANTYPE"], [
])
AC_SUBST(MANTYPE)
+MKMF_VERBOSE=0
+AC_ARG_ENABLE(mkmf-verbose,
+ AS_HELP_STRING([--enable-mkmf-verbose], [enable verbose in mkmf]),
+ [MKMF_VERBOSE=1],
+ [MKMF_VERBOSE=0])
+AC_SUBST(MKMF_VERBOSE)
+
AC_ARG_ENABLE(rubygems,
AS_HELP_STRING([--disable-rubygems], [disable rubygems by default]),
[enable_rubygems="$enableval"], [enable_rubygems=yes])