summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorshyouhei <shyouhei@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2007-09-22 20:58:40 +0000
committershyouhei <shyouhei@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2007-09-22 20:58:40 +0000
commit756354d4a5fd8ca84f5d6100a53da57cb3448a43 (patch)
treec550c290d69ecdfab5056a86d272600bef00fa73
parentde7245982714246631617299b6501fa0a0f472d7 (diff)
* lib/rdoc/options.rb (Options::check_diagram): dot -V output
changed. [ ruby-Bugs-11978 ], Thanks Florian Frank. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_1_8_6@13486 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
-rw-r--r--ChangeLog5
-rw-r--r--lib/rdoc/options.rb4
-rw-r--r--version.h8
3 files changed, 11 insertions, 6 deletions
diff --git a/ChangeLog b/ChangeLog
index b4e3408..4311fe6 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,8 @@
+Sun Sep 23 05:42:35 2007 URABE Shyouhei <shyouhei@ruby-lang.org>
+
+ * lib/rdoc/options.rb (Options::check_diagram): dot -V output
+ changed. [ ruby-Bugs-11978 ], Thanks Florian Frank.
+
Wed Sep 19 11:13:07 2007 Yukihiro Matsumoto <matz@ruby-lang.org>
* bignum.c (bigtrunc): RBIGNUM(x)->len may be zero. out of bound
diff --git a/lib/rdoc/options.rb b/lib/rdoc/options.rb
index 4dfe451..bea7e6b 100644
--- a/lib/rdoc/options.rb
+++ b/lib/rdoc/options.rb
@@ -550,12 +550,12 @@ class Options
ver = nil
IO.popen("dot -V 2>&1") do |io|
ver = io.read
- if ver =~ /dot\s+version(?:\s+gviz)?\s+(\d+)\.(\d+)/
+ if ver =~ /dot.+version(?:\s+gviz)?\s+(\d+)\.(\d+)/
ok = ($1.to_i > 1) || ($1.to_i == 1 && $2.to_i >= 8)
end
end
unless ok
- if ver =~ /^dot version/
+ if ver =~ /^dot.+version/
$stderr.puts "Warning: You may need dot V1.8.6 or later to use\n",
"the --diagram option correctly. You have:\n\n ",
ver,
diff --git a/version.h b/version.h
index 004743f..05b0a3c 100644
--- a/version.h
+++ b/version.h
@@ -1,15 +1,15 @@
#define RUBY_VERSION "1.8.6"
-#define RUBY_RELEASE_DATE "2007-09-19"
+#define RUBY_RELEASE_DATE "2007-09-23"
#define RUBY_VERSION_CODE 186
-#define RUBY_RELEASE_CODE 20070919
-#define RUBY_PATCHLEVEL 107
+#define RUBY_RELEASE_CODE 20070923
+#define RUBY_PATCHLEVEL 108
#define RUBY_VERSION_MAJOR 1
#define RUBY_VERSION_MINOR 8
#define RUBY_VERSION_TEENY 6
#define RUBY_RELEASE_YEAR 2007
#define RUBY_RELEASE_MONTH 9
-#define RUBY_RELEASE_DAY 19
+#define RUBY_RELEASE_DAY 23
#ifdef RUBY_EXTERN
RUBY_EXTERN const char ruby_version[];