summaryrefslogtreecommitdiff
path: root/.travis.yml
diff options
context:
space:
mode:
author卜部昌平 <shyouhei@ruby-lang.org>2020-10-21 05:06:49 (GMT)
committer卜部昌平 <shyouhei@ruby-lang.org>2020-10-23 01:38:34 (GMT)
commit7cf34cfaa3db4b6eb63dba61108956468140564f (patch)
tree5d0e29a0618773e4c526c02ea6e4452aca6f889f /.travis.yml
parent196eada8c696e8344e976b64615a13219aafcb02 (diff)
.github/workflows/spec_guards.yml add
Translate a part of .travis.yml into GitHub Actions workflow.
Notes
Notes: Merged: https://github.com/ruby/ruby/pull/3685
Diffstat (limited to '.travis.yml')
-rw-r--r--.travis.yml24
1 files changed, 0 insertions, 24 deletions
diff --git a/.travis.yml b/.travis.yml
index ee22583..ca36c55 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -233,28 +233,6 @@ env:
zlib1g-dev:armhf
zlib1g:armhf
- - &spec-on-old-ruby
- language: ruby
- before_install:
- install:
- before_script: chmod -R u+w spec/ruby
- # -j randomly hangs.
- script: ruby -C spec/ruby ../mspec/bin/mspec .
-
- - &rubyspec25
- name: Check ruby/spec version guards on Ruby 2.5
- rvm: 2.5.7
- <<: *spec-on-old-ruby
- after_failure:
- - echo "ruby/spec failed on Ruby 2.5. This is likely because of a missing ruby_version_is guard, please add it. See spec/README.md."
-
- - &rubyspec27
- name: Check ruby/spec version guards on Ruby 2.7
- rvm: 2.7.0
- <<: *spec-on-old-ruby
- after_failure:
- - echo "ruby/spec failed on Ruby 2.7. This is likely because of a missing ruby_version_is guard, please add it. See spec/README.md."
-
- &baseruby
name: "BASERUBY: Ruby 2.2"
<<: *gcc-8
@@ -268,8 +246,6 @@ matrix:
- <<: *x86_64-linux
- <<: *i686-linux
- <<: *baseruby
- - <<: *rubyspec25
- - <<: *rubyspec27
# Build every commit (Allowed Failures):
- <<: *arm32-linux
- <<: *arm64-linux